Are third-party plug-ins required to utilize your online resources?

Follow

Facts On File's eLearning Modules require Adobe Reader 9.0 or higher to view PDFs. To view videos we require Adobe Flash Player 9.0 or higher.

 

To download the latest version of Adobe Reader, visit: http://get.adobe.com/reader/

To download the latest version of Adobe Flash, visit: http://get.adobe.com/flashplayer/

0 out of 0 found this helpful

Comments

0 comments

Please sign in to leave a comment.